about summary refs log tree commit diff
path: root/hosts/aptos/services.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/aptos/services.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/hosts/aptos/services.nix b/hosts/aptos/services.nix
index e79bbb5..1168dc2 100644
--- a/hosts/aptos/services.nix
+++ b/hosts/aptos/services.nix
@@ -23,14 +23,18 @@ in
     backup = {
       enable = true;
       user = "fcuny";
-      repository = "sftp:192.168.0.107:/data/slow/backups/users/fcuny";
+      repository = "sftp:192.168.6.40:/";
       exclude = [
         "/home/fcuny/.cache"
         "/home/fcuny/downloads"
         "/home/fcuny/workspace/linux.git"
+        "/home/fcuny/workspace/tmp"
       ];
       timerConfig = { OnCalendar = "06:30"; };
       passwordFile = secrets."restic/repo-users".path;
+      extraOptions = [
+        "sftp.command='ssh fcunybackup@192.168.6.40 -i ${secrets.restic/ssh-key.path} -s sftp'"
+      ];
       paths = [ "/home/fcuny" ];
     };
   };