about summary refs log tree commit diff
path: root/hosts/aptos/hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/aptos/hardware.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/hosts/aptos/hardware.nix b/hosts/aptos/hardware.nix
index 0569203..990ab60 100644
--- a/hosts/aptos/hardware.nix
+++ b/hosts/aptos/hardware.nix
@@ -17,6 +17,7 @@
     options = [ "subvol=nixos" ];
   };
 
+  boot.initrd.luks.devices."system".allowDiscards = true;
   boot.initrd.luks.devices."system".device =
     "/dev/disk/by-uuid/c83a8db7-4215-4864-8a46-b8ca839d8c05";
 
@@ -46,5 +47,7 @@
   my.hardware.intel.enable = true;
   my.hardware.bluetooth.enable = true;
 
+  my.systems.btrfs.enable = true;
+
   powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
 }