about summary refs log tree commit diff
path: root/home/yubikey.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--home/yubikey.nix28
1 files changed, 0 insertions, 28 deletions
diff --git a/home/yubikey.nix b/home/yubikey.nix
deleted file mode 100644
index b18ce5d..0000000
--- a/home/yubikey.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-{ pkgs, lib, config, ... }:
-{
-  home.packages = with pkgs; [ yubikey-manager yubikey-touch-detector ];
-
-  systemd.user.sockets.yubikey-touch-detector = {
-    Unit.Description = "Unix socket activation for YubiKey touch detector service";
-    Socket = {
-      ListenStream = "%t/yubikey-touch-detector.socket";
-      RemoveOnStop = true;
-    };
-    Install.WantedBy = [ "sockets.target" ];
-  };
-
-  systemd.user.services.yubikey-touch-detector = {
-    Unit = {
-      Description = "Detects when your YubiKey is waiting for a touch";
-      Requires = "yubikey-touch-detector.socket";
-    };
-    Service = {
-      ExecStart = "${pkgs.yubikey-touch-detector}/bin/yubikey-touch-detector --libnotify";
-      EnvironmentFile = "-%E/yubikey-touch-detector/service.conf";
-    };
-    Install = {
-      Also = "yubikey-touch-detector.socket";
-      WantedBy = [ "default.target" ];
-    };
-  };
-}