about summary refs log tree commit diff
path: root/home/wm/sway/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--home/wm/sway/default.nix138
1 files changed, 0 insertions, 138 deletions
diff --git a/home/wm/sway/default.nix b/home/wm/sway/default.nix
deleted file mode 100644
index 7ee6791..0000000
--- a/home/wm/sway/default.nix
+++ /dev/null
@@ -1,138 +0,0 @@
-{ config, lib, pkgs, ... }:
-let
-  isEnabled = config.my.home.wm.windowManager == "sway";
-  terminal = config.my.home.terminal.program;
-  modifier = "Mod4"; # `Super` key
-in
-{
-  config = lib.mkIf isEnabled {
-    home.packages = with pkgs; [
-      wlogout
-      brightnessctl
-      pulseaudio
-      grim
-      slurp
-      polkit_gnome
-      xsettingsd
-      swaylock
-      swayidle
-      wl-clipboard
-    ];
-
-    home.sessionVariables = {
-      MOZ_ENABLE_WAYLAND = "1";
-      XDG_CURRENT_DESKTOP = "sway";
-      XDG_SESSION_TYPE = "wayland";
-    };
-
-    programs = {
-      zsh.loginExtra = ''
-        if [ $(ps ax | grep "[s]sh-agent" | wc -l) -eq 0 ] ; then
-          eval $(ssh-agent -s) > /dev/null
-        fi
-        if [ "$(tty)" = "/dev/tty1" ]; then
-          exec sway &> /dev/null
-        fi
-      '';
-
-      zsh.profileExtra = ''
-        if [ $(ps ax | grep "[s]sh-agent" | wc -l) -eq 0 ] ; then
-          eval $(ssh-agent -s) > /dev/null
-        fi
-        if [ "$(tty)" = "/dev/tty1" ]; then
-          exec sway &> /dev/null
-        fi
-      '';
-    };
-
-    wayland.windowManager.sway = {
-      enable = true;
-      # in order to import some variables (e.g. PATH) so that all the
-      # units that will be started have all the required environment
-      # variables
-      extraSessionCommands = "systemctl --user import-environment";
-      # this will start sway-session.target and run
-      # dbus-update-activation-environment
-      systemdIntegration = true;
-      config = {
-        # FIXME: this should be a variable
-        terminal = "alacritty";
-        modifier = modifier;
-        menu = ''${pkgs.wofi}/bin/wofi -S drun -p "app:" -L 10'';
-        bars = [ ];
-        fonts = {
-          names = [ "Source Code Pro" ];
-          size = 10.0;
-        };
-        keybindings = lib.mkOptionDefault {
-          # control the volume
-          "XF86AudioRaiseVolume" =
-            "exec ${pkgs.pulseaudio}/bin/pactl set-sink-volume @DEFAULT_SINK@ +5%";
-          "XF86AudioLowerVolume" =
-            "exec ${pkgs.pulseaudio}/bin/pactl set-sink-volume @DEFAULT_SINK@ -5%";
-          "XF86AudioMute" =
-            "exec ${pkgs.pulseaudio}/bin/pactl set-sink-mute @DEFAULT_SINK@ toggle";
-          "XF86AudioMicMute" =
-            "exec ${pkgs.pulseaudio}/bin/pactl set-source-mute @DEFAULT_SOURCE@ toggle";
-
-          # control brightness
-          "XF86MonBrightnessDown" =
-            "exec ${pkgs.brightnessctl}/bin/brightnessctl set 5%-";
-          "XF86MonBrightnessUp" =
-            "exec ${pkgs.brightnessctl}/bin/brightnessctl set +5%";
-
-          # logout
-          "${modifier}+Escape" = "exec ${pkgs.wlogout}/bin/wlogout";
-
-          # screenshot
-          "${modifier}+s" =
-            "exec ${pkgs.grim}/bin/grim $(xdg-user-dir DOCUMENTS)/screenshots/$(date +'%Y-%m-%d-%H%M%S_screenshot.png')";
-          "${modifier}+Shift+s" =
-            "exec ${pkgs.slurp}/bin/slurp | ${pkgs.grim}/bin/grim -g - $(xdg-user-dir DOCUMENTS)/screenshots/$(date +'%Y-%m-%d-%H%M%S_screenshot.png')";
-
-          # File Manager
-          "${modifier}+p" = "exec ${pkgs.pcmanfm}/bin/pcmanfm";
-        };
-
-        # use `swaymsg -t get_tree' to get the title/name/ID of the applications
-        window = {
-          commands = [
-            {
-              criteria.class = ".blueman-manager-wrapped";
-              command = "floating enable";
-            }
-            {
-              criteria.class = "Pavucontrol";
-              command = "floating enable";
-            }
-          ];
-        };
-
-        input = {
-          "*" = {
-            "xkb_layout" = "us,fr";
-            # map capslock to ctrl, and switch layout using shift+caps
-            "xkb_options" = "ctrl:nocaps,grp:shift_caps_toggle";
-          };
-        };
-
-
-        assigns = {
-          "1" = [{ app_id = "emacs"; }];
-          "2" = [{ app_id = "Alacritty"; }];
-          "3" = [{ app_id = "firefox"; }];
-          "4" = [{ app_id = "org.gnome.Fractal"; }];
-        };
-
-        output = {
-          "*" = {
-            scale = "1.5";
-            bg = "#2E3440 solid_color";
-          };
-          # This is for aptos
-          "eDP-1" = { scale = "1.3"; };
-        };
-      };
-    };
-  };
-}