about summary refs log tree commit diff
path: root/home/wm/mako/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--home/wm/mako/default.nix33
1 files changed, 0 insertions, 33 deletions
diff --git a/home/wm/mako/default.nix b/home/wm/mako/default.nix
deleted file mode 100644
index 325ee3d..0000000
--- a/home/wm/mako/default.nix
+++ /dev/null
@@ -1,33 +0,0 @@
-{ config, lib, pkgs, ... }:
-let isEnabled = config.my.home.wm.windowManager == "sway";
-in
-{
-  config = lib.mkIf isEnabled {
-    home.packages = [
-      pkgs.libnotify # to send notifications
-    ];
-
-    systemd.user.services.mako = {
-      Service = { ExecStart = "${pkgs.mako}/bin/mako"; };
-      Install = { WantedBy = [ "sway-session.target" ]; };
-    };
-
-    # All the options are documented via `man 5 mako`
-    services.mako = {
-      enable = true;
-      layer = "overlay";
-      # The timeout value is in millisecond
-      defaultTimeout = 30000;
-      padding = "10,20";
-      width = 400;
-      height = 150;
-      borderSize = 2;
-      # The maximum number of notifications
-      maxVisible = 3;
-      maxIconSize = 24;
-      # Enable pango markup (see https://docs.gtk.org/Pango/pango_markup.html)
-      markup = true;
-      actions = true;
-    };
-  };
-}