about summary refs log tree commit diff
path: root/home/terminal/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/terminal/default.nix')
-rw-r--r--home/terminal/default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/home/terminal/default.nix b/home/terminal/default.nix
new file mode 100644
index 0000000..e1ff0d7
--- /dev/null
+++ b/home/terminal/default.nix
@@ -0,0 +1,17 @@
+{ config, lib, ... }:
+let cfg = config.my.home.terminal;
+in {
+  imports = [ ./alacritty ];
+  options.my.home = with lib; {
+    terminal = {
+      program = mkOption {
+        type = with types; nullOr (enum [ "alacritty" ]);
+        default = null;
+        example = "alacritty";
+        description = "Which terminal to use for home session";
+      };
+    };
+  };
+  config.home.sessionVariables =
+    lib.mkIf (cfg.program != null) { TERMINAL = cfg.program; };
+}