about summary refs log tree commit diff
path: root/home/terminal/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--home/terminal/default.nix18
1 files changed, 0 insertions, 18 deletions
diff --git a/home/terminal/default.nix b/home/terminal/default.nix
deleted file mode 100644
index 68dcf4b..0000000
--- a/home/terminal/default.nix
+++ /dev/null
@@ -1,18 +0,0 @@
-{ config, lib, ... }:
-let cfg = config.my.home.terminal;
-in
-{
-  imports = [ ./alacritty ];
-  options.my.home = with lib; {
-    terminal = {
-      program = mkOption {
-        type = with types; nullOr (enum [ "alacritty" ]);
-        default = null;
-        example = "alacritty";
-        description = "Which terminal to use for home session";
-      };
-    };
-  };
-  config.home.sessionVariables =
-    lib.mkIf (cfg.program != null) { TERMINAL = cfg.program; };
-}