about summary refs log tree commit diff
path: root/home/shell/fish/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--home/shell/fish/default.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/home/shell/fish/default.nix b/home/shell/fish/default.nix
index 3a21b24..c81f188 100644
--- a/home/shell/fish/default.nix
+++ b/home/shell/fish/default.nix
@@ -2,11 +2,13 @@
 let
   cfg = config.my.home.shell;
   swayEnabled = config.my.home.wm.windowManager == "sway";
+  aliases = config.my.home.shell.aliases;
 in
 {
   config = lib.mkIf (cfg.name == "fish") {
     programs.fish = {
       enable = true;
+      shellAliases = aliases;
       interactiveShellInit = ''
         set fish_greeting