about summary refs log tree commit diff
path: root/home/shell/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/shell/default.nix')
-rw-r--r--home/shell/default.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/home/shell/default.nix b/home/shell/default.nix
index 35a6275..f34d997 100644
--- a/home/shell/default.nix
+++ b/home/shell/default.nix
@@ -1,7 +1,9 @@
 { config, lib, pkgs, ... }:
 
 with lib;
-let cfg = config.my.home.shell;
+let
+  cfg = config.my.home.shell;
+  aliases = import ./aliases.nix;
 in
 {
   options.my.home.shell = {
@@ -10,6 +12,13 @@ in
       type = types.enum [ "fish" "zsh" ];
       example = "zsh";
     };
+    aliases = mkOption {
+      default = aliases;
+      description = ''
+        A wrapper for shellAliases for zsh and fish
+      '';
+      type = types.attrsOf types.str;
+    };
   };
 
   imports = [ ./fish ./zsh ];