about summary refs log tree commit diff
path: root/home/shell/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--home/shell/default.nix25
1 files changed, 0 insertions, 25 deletions
diff --git a/home/shell/default.nix b/home/shell/default.nix
deleted file mode 100644
index f34d997..0000000
--- a/home/shell/default.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-let
-  cfg = config.my.home.shell;
-  aliases = import ./aliases.nix;
-in
-{
-  options.my.home.shell = {
-    name = mkOption {
-      default = "zsh";
-      type = types.enum [ "fish" "zsh" ];
-      example = "zsh";
-    };
-    aliases = mkOption {
-      default = aliases;
-      description = ''
-        A wrapper for shellAliases for zsh and fish
-      '';
-      type = types.attrsOf types.str;
-    };
-  };
-
-  imports = [ ./fish ./zsh ];
-}