about summary refs log tree commit diff
path: root/home/seahorse/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--home/seahorse/default.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/home/seahorse/default.nix b/home/seahorse/default.nix
new file mode 100644
index 0000000..54688a1
--- /dev/null
+++ b/home/seahorse/default.nix
@@ -0,0 +1,9 @@
+{ lib, config, pkgs, ... }:
+let cfg = config.my.home.seahorse;
+in {
+  options.my.home.seahorse = with lib; {
+    enable = mkEnableOption "seahorse configuration";
+  };
+
+  config.home.packages = with pkgs; lib.mkIf cfg.enable ([ gnome.seahorse ]);
+}