about summary refs log tree commit diff
path: root/home/scripts/perf-flamegraph.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--home/scripts/perf-flamegraph.nix23
1 files changed, 0 insertions, 23 deletions
diff --git a/home/scripts/perf-flamegraph.nix b/home/scripts/perf-flamegraph.nix
deleted file mode 100644
index b974e6b..0000000
--- a/home/scripts/perf-flamegraph.nix
+++ /dev/null
@@ -1,23 +0,0 @@
-{ pkgs, config, ... }:
-let
-  perf-flamegraph-process =
-    pkgs.writeShellScriptBin "perf-flamegraph-process" ''
-      set -euo pipefail
-
-      OUT_DIR="''${HOME}/workspace/tmp/flamegraph"
-      OUT_SVG="''${OUT_DIR}/$(date +%y%m%d-%H%M%S).svg"
-
-      mkdir -p ''${OUT_DIR}
-
-      ${pkgs.linuxPackages.perf}/bin/perf record -g --call-graph dwarf -F max "$@"
-      ${pkgs.linuxPackages.perf}/bin/perf script \
-        | ${pkgs.flamegraph}/bin/stackcollapse-perf.pl \
-        | ${pkgs.flamegraph}/bin/flamegraph.pl > "''${OUT_SVG}"
-    '';
-in
-{
-  config = {
-    home.packages = with pkgs; [ flamegraph perf-flamegraph-process ];
-  };
-}
-