about summary refs log tree commit diff
path: root/home/python/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--home/python/default.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/home/python/default.nix b/home/python/default.nix
new file mode 100644
index 0000000..c7069e3
--- /dev/null
+++ b/home/python/default.nix
@@ -0,0 +1,9 @@
+{ pkgs, lib, ... }:
+let cfg = config.my.home.python;
+in {
+  options.my.home.python = with lib.my; {
+    enable = mkEnableOption "python configuration";
+  };
+
+  config.home.packages = with pkgs; lib.mkIf cfg.enable ([ python310 ]);
+}