about summary refs log tree commit diff
path: root/home/python/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--home/python/default.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/home/python/default.nix b/home/python/default.nix
deleted file mode 100644
index 32a2129..0000000
--- a/home/python/default.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-{ config, pkgs, lib, ... }:
-let
-  cfg = config.my.home.python;
-  pythonEnv = pkgs.python3.withPackages (p: with p; [
-    black # format
-    isort # format
-    pylsp-mypy # language server protocol
-    requests # HTTP library
-    types-requests # types for requests (for mypy)
-    pip # to install dependencies
-    ipython # nicer REPL
-  ]);
-in
-{
-  options.my.home.python = with lib; {
-    enable = mkEnableOption "python configuration";
-  };
-
-  config = lib.mkIf cfg.enable {
-    home.packages = with pkgs.python3Packages; [ pythonEnv ];
-
-    home.sessionVariables = with config.xdg; {
-      IPYTHONDIR = "${cacheHome}/ipython";
-      PIP_LOG = "${cacheHome}/pip/pip.log";
-      PYLINTHOME = "${cacheHome}/pylint";
-      PYTHON_EGG_CACHE = "${cacheHome}/python-eggs";
-    };
-  };
-}