about summary refs log tree commit diff
path: root/home/profiles/ssh.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--home/profiles/ssh.nix (renamed from home/ssh/default.nix)10
1 files changed, 2 insertions, 8 deletions
diff --git a/home/ssh/default.nix b/home/profiles/ssh.nix
index eecca99..576f451 100644
--- a/home/ssh/default.nix
+++ b/home/profiles/ssh.nix
@@ -1,12 +1,6 @@
-{ config, lib, ... }:
-let cfg = config.my.home.ssh;
-in
+{ ... }:
 {
-  options.my.home.ssh = with lib; {
-    enable = mkEnableOption "ssh configuration";
-  };
-
-  config.programs.ssh = lib.mkIf cfg.enable {
+  programs.ssh = {
     enable = true;
     forwardAgent = true;
     serverAliveInterval = 60;