about summary refs log tree commit diff
path: root/home/profiles/alacritty.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/alacritty.nix')
-rw-r--r--home/profiles/alacritty.nix51
1 files changed, 51 insertions, 0 deletions
diff --git a/home/profiles/alacritty.nix b/home/profiles/alacritty.nix
new file mode 100644
index 0000000..2789f12
--- /dev/null
+++ b/home/profiles/alacritty.nix
@@ -0,0 +1,51 @@
+{
+  programs.alacritty = {
+    enable = true;
+    settings = {
+      env = {
+        TERM = "xterm-256color";
+      };
+
+      live_config_reload = true;
+      draw_bold_text_with_bright_colors = true;
+      selection = { save_to_clipboard = true; };
+
+      colors = {
+        primary = {
+          background = "#000000";
+          foreground = "#D3D7CF";
+        };
+
+        normal = {
+          black = "#2E3436";
+          red = "#CC0000";
+          green = "#4E9A06";
+          yellow = "#C4A000";
+          blue = "#3465A4";
+          magenta = "#EF33C0";
+          cyan = "#04B5B8";
+          white = "#D3D7CF";
+        };
+
+        bright = {
+          black = "#555753";
+          red = "#EF2929";
+          green = "#8AE234";
+          yellow = "#FCE94F";
+          blue = "#729FCF";
+          magenta = "#EE38DA";
+          cyan = "#34E2E2";
+          white = "#EEEEEC";
+        };
+      };
+      font = {
+        size = 13;
+        normal.family = "Source Code Pro";
+      };
+      cursor = {
+        style.blinking = "Never";
+        unfocused_hollow = true;
+      };
+    };
+  };
+}