about summary refs log tree commit diff
path: root/home/pass/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/pass/default.nix')
-rw-r--r--home/pass/default.nix24
1 files changed, 5 insertions, 19 deletions
diff --git a/home/pass/default.nix b/home/pass/default.nix
index 043ff6c..eb43c3a 100644
--- a/home/pass/default.nix
+++ b/home/pass/default.nix
@@ -3,18 +3,13 @@ let cfg = config.my.home.pass;
 in
 {
   options.my.home.pass = with lib; {
-    enable = mkEnableOption "pass configuration";
+    enable = mkEnableOption "passage configuration";
   };
   config = lib.mkIf cfg.enable {
-    programs.password-store = {
-      enable = true;
-      settings = {
-        PASSWORD_STORE_DIR = "${config.xdg.dataHome}/password-store";
-        PASSWORD_STORE_GENERATED_LENGTH = "30";
-        PASSWORD_STORE_CHARACTER_SET = "a-zA-Z0-9~!@#$%^&*()-_=+[]{};:,.<>?";
-        PASSWORD_STORE_KEY = config.programs.gpg.settings.default-key;
-      };
-    };
+    home.packages = with pkgs; [
+      passage
+      tree
+    ];
 
     home.sessionVariables = {
       PASSAGE_DIR = "${config.xdg.dataHome}/passage/store";
@@ -25,14 +20,5 @@ in
       PASSAGE_AGE = "${pkgs.rage}/bin/rage";
     };
 
-    home.packages = with pkgs; [
-      passage
-      tree
-    ];
-
-    services.password-store-sync.enable = false;
-
-    # Ensure the password store things are in the systemd session
-    systemd.user.sessionVariables = config.programs.password-store.settings;
   };
 }