about summary refs log tree commit diff
path: root/home/pass/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--home/pass/default.nix24
1 files changed, 0 insertions, 24 deletions
diff --git a/home/pass/default.nix b/home/pass/default.nix
deleted file mode 100644
index eb43c3a..0000000
--- a/home/pass/default.nix
+++ /dev/null
@@ -1,24 +0,0 @@
-{ config, lib, pkgs, ... }:
-let cfg = config.my.home.pass;
-in
-{
-  options.my.home.pass = with lib; {
-    enable = mkEnableOption "passage configuration";
-  };
-  config = lib.mkIf cfg.enable {
-    home.packages = with pkgs; [
-      passage
-      tree
-    ];
-
-    home.sessionVariables = {
-      PASSAGE_DIR = "${config.xdg.dataHome}/passage/store";
-      PASSAGE_IDENTITIES_FILE = "${config.xdg.dataHome}/passage/identities";
-      # for now I have to default to rage, as the version of age is
-      # not recent enough to work with keys generated by
-      # age-plugin-yubikey
-      PASSAGE_AGE = "${pkgs.rage}/bin/rage";
-    };
-
-  };
-}