about summary refs log tree commit diff
path: root/home/home.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--home/home.nix69
1 files changed, 0 insertions, 69 deletions
diff --git a/home/home.nix b/home/home.nix
deleted file mode 100644
index 42517b9..0000000
--- a/home/home.nix
+++ /dev/null
@@ -1,69 +0,0 @@
-{ config, lib, pkgs, ... }:
-{
-  imports = [
-    ./git.nix
-    ./ssh.nix
-    ./zsh.nix
-  ];
-
-  home.packages = with pkgs; [
-    dive # explore layers in docker images
-    jq
-    ripgrep
-    util-linux
-    xdg-utils
-
-    age
-    rage
-    age-plugin-yubikey
-
-    # tools inside the tools directory
-    tools.git-blame-stats
-    tools.git-broom
-    tools.ipconverter
-    tools.seqstat
-
-    # tools from external repositories
-    # x509-info
-    # gh-ssh-keys
-    # masked-emails
-  ];
-
-  programs.direnv = {
-    enable = true;
-    nix-direnv.enable = true;
-    config = {
-      global.disable_stdin = true;
-      global.strict_env = true;
-    };
-  };
-
-  xdg = {
-    enable = true;
-    # File types
-    mime.enable = true;
-    # File associatons
-    mimeApps = { enable = true; };
-    # User directories
-    userDirs = {
-      enable = true;
-      createDirectories = true;
-      desktop = "${config.home.homeDirectory}/documents";
-      documents = "${config.home.homeDirectory}/documents";
-      download = "${config.home.homeDirectory}/downloads";
-      music = "${config.home.homeDirectory}/media/music";
-      pictures = "${config.home.homeDirectory}/media/pictures";
-      publicShare = "${config.home.homeDirectory}/documents/public";
-      templates = "${config.home.homeDirectory}/documents/templates";
-      videos = "${config.home.homeDirectory}/media/videos";
-    };
-  };
-
-  home.sessionVariables = with config.xdg; {
-    LESS = "-FRSXM";
-    LESSCHARSET = "utf-8";
-    LESSHISTFILE = "${dataHome}/less/history";
-    LESSKEY = "${configHome}/less/lesskey";
-    PAGER = "less";
-  };
-}