about summary refs log tree commit diff
path: root/home/go/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--home/go/default.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/home/go/default.nix b/home/go/default.nix
index 4cc15ef..a1a97fb 100644
--- a/home/go/default.nix
+++ b/home/go/default.nix
@@ -1,4 +1,4 @@
-{ lib, config, ... }:
+{ lib, config, pkgs, ... }:
 let cfg = config.my.home.go;
 in
 {
@@ -12,7 +12,9 @@ in
       goPath = ".local/share/pkg.go";
       goBin = ".local/bin.go";
       goPrivate = [ "git.fcuny.net" "golang.fcuny.net" ];
+      package = pkgs.go_1_18;
     };
+    home.packages = with pkgs; [ gopls ];
     home.sessionPath = [ config.home.sessionVariables.GOBIN ];
   };
 }