about summary refs log tree commit diff
path: root/home/git/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/git/default.nix')
-rw-r--r--home/git/default.nix22
1 files changed, 1 insertions, 21 deletions
diff --git a/home/git/default.nix b/home/git/default.nix
index 557485b..96affa7 100644
--- a/home/git/default.nix
+++ b/home/git/default.nix
@@ -55,27 +55,7 @@ in
         "credential \"https://github.com\"" = { username = "fcuny"; };
         "credential \"https://git.fcuny.net\"" = { username = "fcuny"; };
       };
-      ignores = [
-        "*.elc"
-        "*.iml"
-        "*.o"
-        "*.pyc"
-        "*.pyo"
-        "*pyc"
-        "*~"
-        ".DS_Store"
-        ".\\#"
-        ".dir-locals.el"
-        ".direnv/*"
-        ".idea"
-        ".projectile"
-        ".pytest_cache/"
-        "/env/*"
-        "Icon"
-        "TAGS"
-        "\\#*\\#"
-        "tags"
-      ];
+      ignores = [ (builtins.readFile ./gitignore) ];
     };
     xdg.dataFile."git/commit.template" = { source = ./commit.template; };
     home.packages = with pkgs; [ tools.git-blame-stats gitAndTools.pre-commit ];