about summary refs log tree commit diff
path: root/home/flac/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/flac/default.nix')
-rw-r--r--home/flac/default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/home/flac/default.nix b/home/flac/default.nix
new file mode 100644
index 0000000..137d353
--- /dev/null
+++ b/home/flac/default.nix
@@ -0,0 +1,17 @@
+{ config, lib, pkgs, ... }:
+let cfg = config.my.home.flac;
+in {
+  options.my.home.flac = with lib; {
+    enable = mkEnableOption "flac configuration";
+  };
+
+  config.home.packages = with pkgs;
+    lib.mkIf cfg.enable ([
+      flac
+      abcde
+      (pkgs.writers.writeDashBin "rip-flac" ''
+        cd ~/import
+        ${pkgs.abcde}/bin/abcde -Vx -G -a "cddb,read,encode,tag,move,clean" -o flac
+      '')
+    ]);
+}