about summary refs log tree commit diff
path: root/home/eog/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--home/eog/default.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/home/eog/default.nix b/home/eog/default.nix
new file mode 100644
index 0000000..c7f784b
--- /dev/null
+++ b/home/eog/default.nix
@@ -0,0 +1,9 @@
+{ lib, config, pkgs, ... }:
+let cfg = config.my.home.eog;
+in {
+  options.my.home.eog = with lib; {
+    enable = mkEnableOption "eog configuration";
+  };
+
+  config.home.packages = with pkgs; lib.mkIf cfg.enable ([ gnome3.eog ]);
+}