about summary refs log tree commit diff
path: root/home/emacs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/emacs/default.nix')
-rw-r--r--home/emacs/default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/home/emacs/default.nix b/home/emacs/default.nix
new file mode 100644
index 0000000..faac80d
--- /dev/null
+++ b/home/emacs/default.nix
@@ -0,0 +1,20 @@
+{ lib, config, pkgs, ... }:
+let cfg = config.my.home.emacs;
+in {
+  options.my.home.emacs = with lib; {
+    enable = mkEnableOption "emacs configuration";
+  };
+
+  config.home = lib.mkIf cfg.enable {
+    packages = with pkgs; [
+      emacsPgtkNativeComp
+      # see https://github.com/hlissner/doom-emacs/issues/4138
+      (aspellWithDicts (dicts: with dicts; [ en en-computers en-science ]))
+    ];
+
+    sessionVariables = {
+      EDITOR = "emacsclient -c -a=";
+      VISUAL = "emacsclient -c -a=";
+    };
+  };
+}