about summary refs log tree commit diff
path: root/home/darwin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/darwin.nix')
-rw-r--r--home/darwin.nix45
1 files changed, 0 insertions, 45 deletions
diff --git a/home/darwin.nix b/home/darwin.nix
deleted file mode 100644
index defd381..0000000
--- a/home/darwin.nix
+++ /dev/null
@@ -1,45 +0,0 @@
-{ config, pkgs, ... }:
-{
-  home.stateVersion = "23.05";
-
-  imports = [
-    ./dev.nix
-    ./firefox.nix
-    ./git.nix
-    ./ssh.nix
-    ./zsh.nix
-  ];
-
-  home.packages = with pkgs; [
-    direnv
-    jless
-    jq
-    nixd
-    nix-direnv
-    nixfmt
-    nixpkgs-fmt
-    ripgrep
-    rnix-lsp
-    tree
-  ];
-
-  home.sessionVariables = {
-    EDITOR = "emacsclient -a=";
-    VISUAL = "emacsclient -a=";
-    LESS = "-FRSXM";
-    LESSCHARSET = "utf-8";
-    PAGER = "less";
-  };
-
-  programs = {
-    direnv = {
-      enable = true;
-      nix-direnv.enable = true;
-      enableZshIntegration = true;
-      config = {
-        global.disable_stdin = true;
-        global.strict_env = true;
-      };
-    };
-  };
-}