about summary refs log tree commit diff
path: root/home/darwin.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--home/darwin.nix13
1 files changed, 10 insertions, 3 deletions
diff --git a/home/darwin.nix b/home/darwin.nix
index ef2787d..b4a49d8 100644
--- a/home/darwin.nix
+++ b/home/darwin.nix
@@ -3,11 +3,10 @@
   home.stateVersion = "23.05";
 
   imports = [
-    ./git.nix
-    ./zsh.nix
     ./dev.nix
-    ./tmux.nix
+    ./git.nix
     ./ssh.nix
+    ./zsh.nix
   ];
 
   home.packages = with pkgs; [
@@ -22,6 +21,14 @@
     tree
   ];
 
+  home.sessionVariables = {
+    EDITOR = "emacsclient -a=";
+    VISUAL = "emacsclient -a=";
+    LESS = "-FRSXM";
+    LESSCHARSET = "utf-8";
+    PAGER = "less";
+  };
+
   programs = {
     direnv = {
       enable = true;