about summary refs log tree commit diff
path: root/flake/devshell.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake/devshell.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/flake/devshell.nix b/flake/devshell.nix
index 6e1d40e..8124ed4 100644
--- a/flake/devshell.nix
+++ b/flake/devshell.nix
@@ -24,6 +24,24 @@
 
         commands = [
           { package = config.treefmt.build.wrapper; }
+          {
+            name = "update";
+            help = "Update + Commit the Lock File";
+            command = "nix flake update --commit-lock-file";
+            category = "nix";
+          }
+          {
+            name = "build-darwin";
+            category = "darwin";
+            help = "Build the current darwin configuration";
+            command = "darwin-rebuild build --flake .#";
+          }
+          {
+            name = "switch-darwin";
+            category = "darwin";
+            help = "Switch to the current darwin configuration";
+            command = "darwin-rebuild switch --flake .#";
+          }
         ];
       };