about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index e792668..bd68281 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,9 +1,12 @@
 {
   description = "personal NixOS configurations";
+
   inputs = {
     # Nixpkgs, NixOS's official repo
     nixpkgs.url = "github:nixos/nixpkgs/release-21.11";
 
+    utils.url = "github:numtide/flake-utils";
+
     # We use the unstable nixpkgs repo for some packages.
     nixpkgs-unstable.url = "github:nixos/nixpkgs/nixpkgs-unstable";
 
@@ -18,7 +21,7 @@
   outputs = { ... }@inputs:
     let
       lib = import ./lib { inherit inputs; };
-    in: {
+    in {
       nixosConfigurations = {
         carmel = lib.mkSystem {
           hostname = "carmel";
@@ -37,7 +40,7 @@
       };
     } // inputs.utils.lib.eachDefaultSystem (system:
       let
-        pkgs = import inputs.nixpkgs { inherit system overlays; };
+        pkgs = import inputs.nixpkgs { inherit system; };
         home-manager = inputs.home-manager.defaultPackage."${system}";
       in
       {