about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 86d32c8..db58906 100644
--- a/flake.nix
+++ b/flake.nix
@@ -29,7 +29,7 @@
   };
 
   # Output config, or config for NixOS system
-  outputs = { ... }@inputs:
+  outputs = { self, ... }@inputs:
     let lib = import ./nix { inherit inputs; };
     in
     {
@@ -42,7 +42,9 @@
       let
         pkgs = import inputs.nixpkgs { inherit system; };
         home-manager = inputs.home-manager.defaultPackage."${system}";
-      in {
+        ci = import ./ops/ci/fmt.nix { inherit pkgs; };
+      in
+      {
         packages = pkgs // {
           inherit home-manager;
 
@@ -58,6 +60,9 @@
           };
         };
 
+        # `nix run .#ci.format` formats in current directory!
+        apps.ci.format = ci.mkFmtScript self;
+
         devShell = pkgs.mkShell {
           buildInputs = with pkgs; [
             nixUnstable