about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 83db950..20a5bd4 100644
--- a/flake.nix
+++ b/flake.nix
@@ -39,7 +39,8 @@
 
   # Output config, or config for NixOS system
   outputs =
-    { nixpkgs
+    { self
+    , nixpkgs
     , darwin
     , flake-utils
     , pre-commit-hooks
@@ -61,6 +62,7 @@
           pre-commit-check = pre-commit-hooks.lib.${system}.run {
             src = ./.;
             hooks = {
+              shellcheck.enable = true;
               nixpkgs-fmt.enable = true;
               check-merge-conflicts.enable = true;
               end-of-file-fixer.enable = true;
@@ -74,6 +76,8 @@
             agenix
             inputs.agenix.packages."${system}".default
           ];
+          devshell.startup.pre-commit.text =
+            self.checks.${system}.pre-commit-check.shellHook;
           env = [{
             name = "DEVSHELL_NO_MOTD";
             value = "1";