about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix46
1 files changed, 5 insertions, 41 deletions
diff --git a/flake.nix b/flake.nix
index b305ac5..072ad80 100644
--- a/flake.nix
+++ b/flake.nix
@@ -11,17 +11,6 @@
 
     futils.url = "github:numtide/flake-utils";
 
-    emacs-overlay.url = "github:nix-community/emacs-overlay";
-
-    naersk.url = "github:nix-community/naersk";
-
-    agenix = {
-      url = "github:ryantm/agenix";
-      inputs.nixpkgs.follows = "nixpkgs";
-    };
-
-    nur.url = "github:nix-community/NUR";
-
     home-manager = {
       type = "github";
       owner = "nix-community";
@@ -32,19 +21,11 @@
       };
     };
 
-    homeage = {
-      url = "github:jordanisaacs/homeage";
-      inputs.nixpkgs.follows = "nixpkgs";
-    };
-
-    rust = {
-      url = "github:oxalica/rust-overlay";
+    darwin = {
+      url = "github:lnl7/nix-darwin";
       inputs.nixpkgs.follows = "nixpkgs";
     };
 
-    darwin.url = "github:lnl7/nix-darwin";
-    darwin.inputs.nixpkgs.follows = "nixpkgs";
-
     pre-commit-hooks = {
       type = "github";
       owner = "cachix";
@@ -63,7 +44,7 @@
     let
       myLib = import ./nix inputs;
       lib = inputs.nixpkgs.lib // builtins;
-      supportedSystems = [ "x86_64-linux" "aarch64-darwin" ];
+      supportedSystems = [ "aarch64-darwin" ];
       forAllSystems = lib.genAttrs supportedSystems;
 
       # Nixpkgs instantiated for supported system types.
@@ -155,31 +136,14 @@
           tools = import ./tools { inherit pkgs; };
         });
 
-      nixosConfigurations = {
-        aptos = myLib.mkSystem { hostname = "aptos"; };
-        carmel = myLib.mkSystem { hostname = "carmel"; };
-        tahoe = myLib.mkSystem { hostname = "tahoe"; };
-      };
-
       darwinConfigurations = {
         "mba-fcuny" = darwin.lib.darwinSystem {
           system = "aarch64-darwin";
           modules = [
-              home-manager.darwinModules.home-manager
-              ./hosts/mba
+            home-manager.darwinModules.home-manager
+            ./hosts/mba
           ];
         };
       };
-
-      homeConfigurations = {
-        useGlobalPkgs = true;
-        useUserPackages = true;
-
-        "fcuny@aptos" =
-          myLib.mkHomeManagerConfiguration { hostname = "aptos"; };
-
-        "fcuny@tahoe" =
-          myLib.mkHomeManagerConfiguration { hostname = "tahoe"; };
-      };
     };
 }