about summary refs log tree commit diff
path: root/users/fcuny/desktop/xdg.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-12 13:22:29 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-12 13:23:58 -0800
commit60da6bc47620681b557ea2d105df87b22382efcd (patch)
tree000a2c858a5bbcd9d0e9ed1c5bd57546420f65d0 /users/fcuny/desktop/xdg.nix
parenthome-manager: last typo (diff)
downloadworld-60da6bc47620681b557ea2d105df87b22382efcd.tar.gz
home-manager: re-organize configuration for myself
Diffstat (limited to '')
-rw-r--r--users/fcuny/desktop/xdg.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/users/fcuny/desktop/xdg.nix b/users/fcuny/desktop/xdg.nix
new file mode 100644
index 0000000..7390811
--- /dev/null
+++ b/users/fcuny/desktop/xdg.nix
@@ -0,0 +1,18 @@
+{ config, lib, pkgs, ... }:
+
+{
+  xdg.enable = true;
+
+  xdg.userDirs = {
+    enable = true;
+    createDirectories = true;
+    desktop = "\$HOME/documents";
+    documents = "\$HOME/documents";
+    download = "\$HOME/downloads";
+    music = "\$HOME/media/music";
+    pictures = "\$HOME/media/pictures";
+    publicShare = "\$HOME/documents/public";
+    templates = "\$HOME/documents/templates";
+    videos = "\$HOME/media/videos";
+  };
+}