about summary refs log tree commit diff
path: root/users/fcuny/desktop/sway/waybar.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-21 08:33:52 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-21 08:43:35 -0800
commit0636d7ac99e6b25a0f9df986333a3cb4395bc112 (patch)
tree0a9474c00200c7905b4e11cec0dfac508ba8ff1c /users/fcuny/desktop/sway/waybar.nix
parentterminal: a few more tweaks to alacritty (diff)
downloadworld-0636d7ac99e6b25a0f9df986333a3cb4395bc112.tar.gz
sway: switch to i3status and set keybindings
Replace waybar with i3status. I keep running into issues with
waybar (does not start, for example), and i3 status is a bit easier to
configure.

Set some keybindings so I can adjust volume and brightness.
Diffstat (limited to '')
-rw-r--r--users/fcuny/desktop/sway/waybar.nix102
1 files changed, 0 insertions, 102 deletions
diff --git a/users/fcuny/desktop/sway/waybar.nix b/users/fcuny/desktop/sway/waybar.nix
deleted file mode 100644
index eeabe14..0000000
--- a/users/fcuny/desktop/sway/waybar.nix
+++ /dev/null
@@ -1,102 +0,0 @@
-{ config, pkgs, lib, ... }:
-
-{
-  programs.waybar = {
-    enable = true;
-    systemd.enable = true;
-    settings = [{
-      layer = "top";
-      position = "top";
-      height = 20;
-      modules-left = ["sway/workspaces" "sway/mode"];
-      modules-center = ["sway/window"];
-      modules-right = [ "mpd" "network" "pulseaudio" "battery" "clock" ];
-      modules = {
-        "network" = {
-          format-wifi = "{essid}:{signalStrength}%";
-          format-ethernet = "{ifname}: {ipaddr}";
-          format-disconnected = "Disconnected";
-        };
-        "pulseaudio" = {
-          format = "{volume}%";
-          "on-click" = "${pkgs.pavucontrol}/bin/pavucontrol";
-        };
-        "clock" = {
-          format = "{:%a %d %b %H:%M}";
-        };
-      };
-    }];
-
-    style = ''
-    * {
-      border: none;
-      border-radius: 0;
-      min-height: 0;
-      margin: 0;
-      padding: 0;
-    }
-
-    #waybar {
-      background: #000000;
-      color: white;
-      font-family: Source Code Pro;
-      font-size: 12px;
-    }
-
-    #clock,
-    #mode,
-    #network,
-    #pulseaudio {
-      padding-left: 10px;
-      padding-right: 10px;
-    }
-
-    #clock {
-      font-weight: bold;
-    }
-
-    #mode {
-      background: #64727D;
-      border-top: 2px solid white;
-      padding-bottom: 2px;
-    }
-
-    #network {
-    }
-
-    #network.disconnected {
-      color: orange;
-    }
-
-    #pulseaudio {
-    }
-
-    #pulseaudio.muted {
-    }
-
-    #window {
-      font-weight: bold;
-    }
-
-    #workspaces button {
-      border-top: 2px solid transparent;
-      /* To compensate for the top border and still have vertical centering */
-      padding-bottom: 2px;
-      padding-left: 10px;
-      padding-right: 10px;
-      color: #888888;
-    }
-
-    #workspaces button.focused {
-      border-color: #4c7899;
-      color: white;
-      background-color: #285577;
-    }
-
-    #workspaces button.urgent {
-      border-color: #c9545d;
-      color: #c9545d;
-    }
-    '';
-  };
-}