about summary refs log tree commit diff
path: root/users/fcuny/desktop/sway/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-13 12:03:41 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-13 12:03:41 -0800
commiteebd938fa14164f6f9412e2f61f733a43894dda5 (patch)
tree772f7785a068a3de783b564e46d31934f53e7b02 /users/fcuny/desktop/sway/default.nix
parentcli: this is not working (diff)
downloadworld-eebd938fa14164f6f9412e2f61f733a43894dda5.tar.gz
sway: adjust configuration
Create a new directory to have all things related to sway.

Add some extra configuration for wofi.
Diffstat (limited to '')
-rw-r--r--users/fcuny/desktop/sway/default.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/users/fcuny/desktop/sway/default.nix b/users/fcuny/desktop/sway/default.nix
new file mode 100644
index 0000000..d4d9093
--- /dev/null
+++ b/users/fcuny/desktop/sway/default.nix
@@ -0,0 +1,39 @@
+{ config, lib, pkgs, ... }:
+
+{
+  imorts = [
+    ./wofi.nix
+  ];
+
+  home.packages = [
+    pkgs.pavucontrol
+    pkgs.wofi
+    pkgs.wl-clipboard
+    pkgs.wf-recorder
+  ];
+
+  home.sessionVariables = {
+    MOZ_ENABLE_WAYLAND = true;
+    LIBSEAT_BACKEND = "logind";
+  };
+
+  wayland.windowManager.sway = {
+    enable = true;
+    systemdIntegration = true;
+    config = rec {
+      modifier = "Mod4";
+      terminal = "${config.programs.alacritty.package}/bin/alacritty";
+      menu = "${pkgs.wofi}/bin/wofi -S run";
+      defaultWorkspace = "workspace number 1";
+      startup = [
+        # Initial lock
+        { command = "${pkgs.swaylock-effects}/bin/swaylock"; }
+        # Start idle daemon
+        { command = "${pkgs.swayidle}/bin/swayidle -w"; }
+        # Start waybar
+        { command = "${pkgs.waybar}/bin/waybar"; }
+      ];
+      bars = [ ];
+    };
+  };
+}