about summary refs log tree commit diff
path: root/users/fcuny/desktop/sway.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-13 12:03:41 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-13 12:03:41 -0800
commiteebd938fa14164f6f9412e2f61f733a43894dda5 (patch)
tree772f7785a068a3de783b564e46d31934f53e7b02 /users/fcuny/desktop/sway.nix
parentcli: this is not working (diff)
downloadworld-eebd938fa14164f6f9412e2f61f733a43894dda5.tar.gz
sway: adjust configuration
Create a new directory to have all things related to sway.

Add some extra configuration for wofi.
Diffstat (limited to '')
-rw-r--r--users/fcuny/desktop/sway.nix40
1 files changed, 0 insertions, 40 deletions
diff --git a/users/fcuny/desktop/sway.nix b/users/fcuny/desktop/sway.nix
deleted file mode 100644
index 0f1631e..0000000
--- a/users/fcuny/desktop/sway.nix
+++ /dev/null
@@ -1,40 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-{
-  imorts = [
-    ./swayidle.nix
-    ./wofi.nix
-  ]
-
-  home.packages = with pkgs; [
-    pavucontrol
-    wofi
-    wl-clipboard
-    wf-recorder
-  ];
-
-  home.sessionVariables = {
-    MOZ_ENABLE_WAYLAND = true;
-    LIBSEAT_BACKEND = "logind";
-  };
-
-  wayland.windowManager.sway = {
-    enable = true;
-    systemdIntegration = true;
-    wrapperFeatures.gtk = true;
-    config = rec {
-      modifier = "Mod4";
-      terminal = "${config.programs.alacritty.package}/bin/alacritty";
-      menu = "${pkgs.wofi}/bin/wofi -S run";
-    };
-    defaultWorkspace = "workspace number 1";
-    startup = [
-      # Initial lock
-      { command = "${pkgs.swaylock-effects}/bin/swaylock"; }
-      # Start idle daemon
-      { command = "${pkgs.swayidle}/bin/swayidle -w"; }
-      # Start waybar
-      { command = "${pkgs.waybar}/bin/waybar"; }
-    ];
-  };
-}