about summary refs log tree commit diff
path: root/tools/seqstat/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-10-29 13:19:08 -0700
committerFranck Cuny <franck@fcuny.net>2022-10-29 13:19:08 -0700
commitcb3d6d323442e75d83f6e8d2f1a487d4ae948902 (patch)
tree54b55ea77863303734328f4b9a56b92ec6b863fc /tools/seqstat/default.nix
parentref(hosts/tahoe): disable cgit/gerrit/buildkite/sourcegraph (diff)
downloadworld-cb3d6d323442e75d83f6e8d2f1a487d4ae948902.tar.gz
fix(tools): install dependencies correctly
For the python tools, we need the python runtime to be available. For
this we need to specify the dependencies in `propagatedBuildInputs`.

The same is true for flamegraph and perf.
Diffstat (limited to '')
-rw-r--r--tools/seqstat/default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/seqstat/default.nix b/tools/seqstat/default.nix
index d45f4bf..274eba8 100644
--- a/tools/seqstat/default.nix
+++ b/tools/seqstat/default.nix
@@ -5,7 +5,8 @@ stdenvNoCC.mkDerivation rec {
   src = ./seqstat.py;
   version = "0.1.0";
 
-  buildInputs = [ python3 ];
+  buildInputs = with pkgs; [ python3 ];
+  propagatedBuildInputs = with pkgs; [ python3 ];
 
   dontUnpack = true;
   dontBuild = true;