about summary refs log tree commit diff
path: root/tools/perf-flamegraph-pid/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-10-25 19:33:09 -0700
committerFranck Cuny <franck@fcuny.net>2022-10-25 19:33:09 -0700
commit15545d95dc1ea55240f4be08c65f4ec64c46f49f (patch)
treecbc23d56b1fa013d22124033c83f9b51e599831b /tools/perf-flamegraph-pid/default.nix
parentref(ops/github): finished the migration of my repositories (diff)
downloadworld-15545d95dc1ea55240f4be08c65f4ec64c46f49f.tar.gz
ref(tools/perf-flamegraph): move to a proper shell script
I don't want to inline shell scripts inside nix configuration, as it
prevents me to use `shellcheck` to validate them for example.

The script is now moved into the tool directory, and is a tiny bit more
flexible, so that I can run it as my own user.
Diffstat (limited to '')
-rw-r--r--tools/perf-flamegraph-pid/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/tools/perf-flamegraph-pid/default.nix b/tools/perf-flamegraph-pid/default.nix
new file mode 100644
index 0000000..d3b3e1e
--- /dev/null
+++ b/tools/perf-flamegraph-pid/default.nix
@@ -0,0 +1,24 @@
+{ lib, stdenvNoCC, pkgs, config }:
+
+stdenvNoCC.mkDerivation rec {
+  pname = "perf-flamegraph-pid";
+  src = ./perf-flamegraph-pid.sh;
+  version = "0.1.0";
+
+  nativeBuildInputs = with pkgs; [ flamegraph linuxPackages_latest.perf ];
+
+  dontUnpack = true;
+  dontBuild = true;
+
+  installPhase = ''
+    mkdir -p $out/bin
+    cp $src $out/bin/${pname}
+  '';
+
+  meta = with lib; {
+    description = "Generate a process' flame graph.";
+    license = with licenses; [ mit ];
+    platforms = platforms.unix;
+    maintainers = with maintainers; [ fcuny ];
+  };
+}