about summary refs log tree commit diff
path: root/tools/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-10-25 19:33:09 -0700
committerFranck Cuny <franck@fcuny.net>2022-10-25 19:33:09 -0700
commit15545d95dc1ea55240f4be08c65f4ec64c46f49f (patch)
treecbc23d56b1fa013d22124033c83f9b51e599831b /tools/default.nix
parentref(ops/github): finished the migration of my repositories (diff)
downloadworld-15545d95dc1ea55240f4be08c65f4ec64c46f49f.tar.gz
ref(tools/perf-flamegraph): move to a proper shell script
I don't want to inline shell scripts inside nix configuration, as it
prevents me to use `shellcheck` to validate them for example.

The script is now moved into the tool directory, and is a tiny bit more
flexible, so that I can run it as my own user.
Diffstat (limited to '')
-rw-r--r--tools/default.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/default.nix b/tools/default.nix
index 543882f..7003b8a 100644
--- a/tools/default.nix
+++ b/tools/default.nix
@@ -8,4 +8,5 @@ pkgs.lib.makeScope pkgs.newScope (pkgs: {
   git-blame-stats = pkgs.callPackage ./git-blame-stats { };
   git-broom = pkgs.callPackage ./git-broom { };
   sendsms = pkgs.callPackage ./sendsms { };
+  perf-flamegraph-pid = pkgs.callPackage ./perf-flamegraph-pid { };
 })