about summary refs log tree commit diff
path: root/secrets.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-04-10 14:44:33 -0700
committerFranck Cuny <franck@fcuny.net>2022-04-10 14:44:33 -0700
commit6a5cb9b7544168e7136ab2dbd833c9fc63020db7 (patch)
tree88db9fe9f436648acba60ffea98fd47942343b74 /secrets.nix
parentadd a module for backup with restic (diff)
downloadworld-6a5cb9b7544168e7136ab2dbd833c9fc63020db7.tar.gz
secrets: move all the secrets under module/
Refactor a bit the configuration, which should simplify the management
and usage of secrets from now on.
Diffstat (limited to '')
-rw-r--r--secrets.nix28
1 files changed, 0 insertions, 28 deletions
diff --git a/secrets.nix b/secrets.nix
deleted file mode 100644
index ae0efaf..0000000
--- a/secrets.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-let
-  fcuny_aptos =
-    "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIIdlm/qoR/dnMjZhVSTtqFzkgN3Yf9eQ3pgKMiipg+dl";
-  users = [ fcuny_aptos ];
-
-  aptos =
-    "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIOTcPGaiL+/Mwl8JzLHrBwas7QvWPjix4lnaAA1tw+5t";
-  tahoe =
-    "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIEq1IQRvj2jofCHOO6M28w2SRdgtHU06NJvwAwv/b69F";
-
-  systems = [ aptos tahoe ];
-in {
-  "secrets/network/aptos/wireguard_privatekey.age".publicKeys =
-    [ fcuny_aptos aptos ];
-
-  "secrets/network/tahoe/wireguard_privatekey.age".publicKeys =
-    [ fcuny_aptos aptos tahoe ];
-
-  "secrets/traefik/gcp_service_account.json.age".publicKeys =
-    [ fcuny_aptos aptos tahoe ];
-
-  "secrets/unifi/unifi-poller.age".publicKeys = [ fcuny_aptos aptos tahoe ];
-
-  "secrets/restic/repo-systems.age".publicKeys = [ fcuny_aptos aptos tahoe ];
-  "secrets/rclone/config.ini.age".publicKeys = [ fcuny_aptos aptos tahoe ];
-  "secrets/rclone/gcs_service_account.json.age".publicKeys =
-    [ fcuny_aptos aptos tahoe ];
-}