about summary refs log tree commit diff
path: root/profiles/trusted/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-04-08 08:31:15 -0700
committerFranck Cuny <franck@fcuny.net>2022-04-08 08:31:15 -0700
commitab204364dfeefc4069a37e1070ee8009f34ecf4d (patch)
tree304ee131838ab62f545e524c1d954e693ef6687a /profiles/trusted/default.nix
parentmodules: add a few more (diff)
downloadworld-ab204364dfeefc4069a37e1070ee8009f34ecf4d.tar.gz
profiles: create a few new profiles
Diffstat (limited to '')
-rw-r--r--profiles/trusted/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/profiles/trusted/default.nix b/profiles/trusted/default.nix
new file mode 100644
index 0000000..9567ddb
--- /dev/null
+++ b/profiles/trusted/default.nix
@@ -0,0 +1,16 @@
+{ config, lib, ... }:
+let cfg = config.my.profiles.trusted;
+in {
+  options.my.profiles.trusted = with lib; {
+    enable = mkEnableOption "trusted profile";
+  };
+  config = lib.mkIf cfg.enable {
+    my.home.gpg = {
+      enable = true;
+      pinentry = "gnome3";
+      defaultKey = "23348B57F01D4234B5CFBA0923208AC01EB6EEA1";
+    };
+    my.home.mail.enable = true;
+    my.home.pass.enable = true;
+  };
+}