about summary refs log tree commit diff
path: root/profiles/multimedia/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-06-09 09:03:40 -0700
committerFranck Cuny <franck@fcuny.net>2022-06-09 09:33:48 -0700
commit11ec444ec77ec913d0aff34b19a58bb0308904f7 (patch)
tree3ab50a3a0dd3b6516ba485cf0349c6fca888befc /profiles/multimedia/default.nix
parentref(sane): move sane's configuration to correct place (diff)
downloadworld-11ec444ec77ec913d0aff34b19a58bb0308904f7.tar.gz
ref(multimedia): move multimedia modules to hosts
Consume the modules related to multimedia applications at the host
level, instead of having a level of indirection with a profile.

Change-Id: I567f0e01cbfe591beaa2e9086e33434402a4a002
Reviewed-on: https://cl.fcuny.net/c/world/+/292
Reviewed-by: Franck Cuny <franck@fcuny.net>
Diffstat (limited to '')
-rw-r--r--profiles/multimedia/default.nix12
1 files changed, 0 insertions, 12 deletions
diff --git a/profiles/multimedia/default.nix b/profiles/multimedia/default.nix
deleted file mode 100644
index 4c1d3fe..0000000
--- a/profiles/multimedia/default.nix
+++ /dev/null
@@ -1,12 +0,0 @@
-{ config, lib, ... }:
-let cfg = config.my.profiles.multimedia;
-in {
-  options.my.profiles.multimedia = with lib; {
-    enable = mkEnableOption "multimedia profile";
-  };
-  config = lib.mkIf cfg.enable {
-    my.home.vlc.enable = true;
-    my.home.mpv.enable = true;
-    my.home.sublime-music.enable = true;
-  };
-}