about summary refs log tree commit diff
path: root/profiles/laptop.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-05-01 19:42:25 -0700
committerFranck Cuny <franck@fcuny.net>2023-05-01 19:42:25 -0700
commitf6988202567bc5550d412f5e70125cd5e049a501 (patch)
tree1bd202120a78c0a9b938d1d7fd657bce1f9766ce /profiles/laptop.nix
parentprofiles/workstation: reduce the number of moving parts (diff)
downloadworld-f6988202567bc5550d412f5e70125cd5e049a501.tar.gz
profiles/laptop: consolidate services related to laptop
Diffstat (limited to '')
-rw-r--r--profiles/laptop.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/profiles/laptop.nix b/profiles/laptop.nix
new file mode 100644
index 0000000..6b8211a
--- /dev/null
+++ b/profiles/laptop.nix
@@ -0,0 +1,13 @@
+{ pkgs, config, lib, ... }:
+{
+  services.thermald.enable = true;
+  services.tlp.enable = true;
+  services.tlp.settings = {
+    CPU_SCALING_GOVERNOR_ON_AC = "schedutil";
+    CPU_SCALING_GOVERNOR_ON_BAT = "schedutil";
+
+    # Keep charge between 60% and 80% to preserve battery life
+    START_CHARGE_THRESH_BAT0 = 60;
+    STOP_CHARGE_THRESH_BAT0 = 80;
+  };
+}