about summary refs log tree commit diff
path: root/profiles/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-05-02 08:06:42 -0700
committerFranck Cuny <franck@fcuny.net>2023-05-02 08:06:42 -0700
commitf21ef4ad2140e050130eb29e61c714074a2fa9de (patch)
tree8e3877bb42ee35635028f687668a05199ab8cbb8 /profiles/default.nix
parentprofiles/default: more consolidation (diff)
downloadworld-f21ef4ad2140e050130eb29e61c714074a2fa9de.tar.gz
profiles/default: move default packages there
Diffstat (limited to '')
-rw-r--r--profiles/default.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/profiles/default.nix b/profiles/default.nix
index 7421144..7a2e6af 100644
--- a/profiles/default.nix
+++ b/profiles/default.nix
@@ -57,4 +57,49 @@
       options = "--delete-older-than 14d";
     };
   };
+
+  environment.shells = with pkgs; [ bashInteractive ];
+
+  environment.systemPackages = with pkgs; [
+    binutils
+    cacert
+    curl
+    dmidecode
+    ethtool
+    flamegraph
+    git
+    htop
+    hwdata
+    iftop
+    iptraf-ng
+    linuxPackages.cpupower
+    config.boot.kernelPackages.perf
+    lm_sensors
+    lsb-release
+    lsof
+    man-pages
+    mg
+    mtr
+    numactl
+    parted
+    pciutils
+    perf-tools
+    powertop
+    rsync
+    sqlite
+    strace
+    tcpdump
+    tmux
+    traceroute
+    unzip
+    usbutils
+    vim
+    wget
+    wireguard-tools
+
+    # my custom tools
+    tools.perf-flamegraph-pid
+  ];
+
+  programs.bcc.enable = true;
 }