about summary refs log tree commit diff
path: root/packages/perf-flamegraph-pid/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-12-19 12:54:16 -0800
committerFranck Cuny <franck@fcuny.net>2024-12-19 12:54:16 -0800
commitbc40b7e0ad2ef5960b7f1695b4520909252a0e49 (patch)
treef22e9e5001720bbc82055a5d4d3b24077b9647de /packages/perf-flamegraph-pid/default.nix
parentuse treefmt to format all the files (diff)
downloadworld-bc40b7e0ad2ef5960b7f1695b4520909252a0e49.tar.gz
switch to the newer version of nixfmt
`nixfmt-rfc-style' replaces `nixfmt-classic'. It's actively
maintained, but also changes the style, so this commit touches all the
files in the repository.
Diffstat (limited to '')
-rw-r--r--packages/perf-flamegraph-pid/default.nix16
1 files changed, 13 insertions, 3 deletions
diff --git a/packages/perf-flamegraph-pid/default.nix b/packages/perf-flamegraph-pid/default.nix
index 0cd0a1b..9b3789b 100644
--- a/packages/perf-flamegraph-pid/default.nix
+++ b/packages/perf-flamegraph-pid/default.nix
@@ -1,12 +1,22 @@
-{ lib, stdenvNoCC, pkgs }:
+{
+  lib,
+  stdenvNoCC,
+  pkgs,
+}:
 
 stdenvNoCC.mkDerivation rec {
   pname = "perf-flamegraph-pid";
   src = ./perf-flamegraph-pid.sh;
   version = "0.1.0";
 
-  nativeBuildInputs = with pkgs; [ flamegraph linuxPackages_latest.perf ];
-  propagatedBuildInputs = with pkgs; [ flamegraph linuxPackages_latest.perf ];
+  nativeBuildInputs = with pkgs; [
+    flamegraph
+    linuxPackages_latest.perf
+  ];
+  propagatedBuildInputs = with pkgs; [
+    flamegraph
+    linuxPackages_latest.perf
+  ];
 
   dontUnpack = true;
   dontBuild = true;