about summary refs log tree commit diff
path: root/nix/users/fcuny/ssh.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-12-19 12:54:16 -0800
committerFranck Cuny <franck@fcuny.net>2024-12-19 12:54:16 -0800
commitbc40b7e0ad2ef5960b7f1695b4520909252a0e49 (patch)
treef22e9e5001720bbc82055a5d4d3b24077b9647de /nix/users/fcuny/ssh.nix
parentuse treefmt to format all the files (diff)
downloadworld-bc40b7e0ad2ef5960b7f1695b4520909252a0e49.tar.gz
switch to the newer version of nixfmt
`nixfmt-rfc-style' replaces `nixfmt-classic'. It's actively
maintained, but also changes the style, so this commit touches all the
files in the repository.
Diffstat (limited to '')
-rw-r--r--nix/users/fcuny/ssh.nix19
1 files changed, 14 insertions, 5 deletions
diff --git a/nix/users/fcuny/ssh.nix b/nix/users/fcuny/ssh.nix
index 2129650..004d44f 100644
--- a/nix/users/fcuny/ssh.nix
+++ b/nix/users/fcuny/ssh.nix
@@ -1,4 +1,5 @@
-{ ... }: {
+{ ... }:
+{
   # https://github.com/nix-community/home-manager/blob/master/modules/programs/ssh.nix
   programs.ssh = {
     enable = true;
@@ -12,26 +13,34 @@
         hostname = "github.com";
         user = "git";
         forwardAgent = false;
-        extraOptions = { preferredAuthentications = "publickey"; };
+        extraOptions = {
+          preferredAuthentications = "publickey";
+        };
       };
       "github.rbx.com" = {
         hostname = "github.rbx.com";
         user = "git";
         forwardAgent = false;
-        extraOptions = { preferredAuthentications = "publickey"; };
+        extraOptions = {
+          preferredAuthentications = "publickey";
+        };
       };
       "git" = {
         hostname = "git.fcuny.net";
         port = 422;
         user = "git";
         forwardAgent = false;
-        extraOptions = { preferredAuthentications = "publickey"; };
+        extraOptions = {
+          preferredAuthentications = "publickey";
+        };
       };
       "home" = {
         hostname = "fcuny.net";
         port = 422;
         user = "fcuny";
-        extraOptions = { preferredAuthentications = "publickey"; };
+        extraOptions = {
+          preferredAuthentications = "publickey";
+        };
       };
     };
   };