about summary refs log tree commit diff
path: root/nix/users/fcuny/ssh.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-12-16 09:25:23 -0800
committerFranck Cuny <franck@fcuny.net>2024-12-16 09:25:23 -0800
commit1bbd4e19c5595e6a6c310bd36fac5b4bd97ff39f (patch)
treee5ec852d0aa9378a5fae766f70d4c133acd5f8d1 /nix/users/fcuny/ssh.nix
parentmove gitotlite to vm-synology (diff)
downloadworld-1bbd4e19c5595e6a6c310bd36fac5b4bd97ff39f.tar.gz
refactor home-manager
Only install what's needed for specific OSes.
Diffstat (limited to '')
-rw-r--r--nix/users/fcuny/ssh.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/nix/users/fcuny/ssh.nix b/nix/users/fcuny/ssh.nix
new file mode 100644
index 0000000..17c2f03
--- /dev/null
+++ b/nix/users/fcuny/ssh.nix
@@ -0,0 +1,38 @@
+{ ... }: {
+  # https://github.com/nix-community/home-manager/blob/master/modules/programs/ssh.nix
+  programs.ssh = {
+    enable = true;
+    forwardAgent = true;
+    serverAliveInterval = 60;
+    controlMaster = "auto";
+    controlPersist = "30m";
+
+    matchBlocks = {
+      "personal" = {
+        hostname = "github.com";
+        user = "git";
+        forwardAgent = false;
+        extraOptions = { preferredAuthentications = "publickey"; };
+      };
+      "github.com" = {
+        hostname = "github.com";
+        user = "git";
+        forwardAgent = false;
+        extraOptions = { preferredAuthentications = "publickey"; };
+      };
+      "github.rbx.com" = {
+        hostname = "github.rbx.com";
+        user = "git";
+        forwardAgent = false;
+        extraOptions = { preferredAuthentications = "publickey"; };
+      };
+      "git" = {
+        hostname = "git.fcuny.net";
+        port = 422;
+        user = "git";
+        forwardAgent = false;
+        extraOptions = { preferredAuthentications = "publickey"; };
+      };
+    };
+  };
+}