about summary refs log tree commit diff
path: root/nix/users/fcuny/shell.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-12-16 10:12:58 -0800
committerFranck Cuny <franck@fcuny.net>2024-12-16 10:12:58 -0800
commit5e31b3dd64f090f9405d9ab9e8e63093b8ad3cc2 (patch)
tree84967fd982d2e9c8606665fb58762567e17f15bb /nix/users/fcuny/shell.nix
parentrefactor home-manager (diff)
downloadworld-5e31b3dd64f090f9405d9ab9e8e63093b8ad3cc2.tar.gz
some more cleanup
Diffstat (limited to '')
-rw-r--r--nix/users/fcuny/shell.nix47
1 files changed, 28 insertions, 19 deletions
diff --git a/nix/users/fcuny/shell.nix b/nix/users/fcuny/shell.nix
index 09fbc40..bfedc45 100644
--- a/nix/users/fcuny/shell.nix
+++ b/nix/users/fcuny/shell.nix
@@ -1,25 +1,34 @@
-{ config, pkgs, ... }: {
-  home.packages = with pkgs; [
-    # shell
-    shellcheck
+{ config, pkgs, ... }:
+let isLinux = pkgs.stdenv.isLinux;
+in {
+  home.packages = with pkgs;
+    [
+      # shell
+      shellcheck
 
-    # shell utils
-    coreutils
-    direnv
-    dust
-    procs
-    ripgrep
-    tree
-    wget
+      # shell utils
+      coreutils
+      direnv
+      dust
+      procs
+      ripgrep
+      tree
+      wget
 
-    # network
-    bandwhich
+      # network
+      bandwhich
 
-    # data manipulation
-    jless
-    jq
-    yq
-  ];
+      # data manipulation
+      jless
+      jq
+      yq
+
+      # dicts
+      aspell
+      aspellDicts.en
+      aspellDicts.en-computers
+      aspellDicts.en-science
+    ] ++ (lib.optionals (isLinux) [ htop ]);
 
   programs.fish = {
     enable = true;