about summary refs log tree commit diff
path: root/nix/users/fcuny/home-manager.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-12-16 10:12:58 -0800
committerFranck Cuny <franck@fcuny.net>2024-12-16 10:12:58 -0800
commit5e31b3dd64f090f9405d9ab9e8e63093b8ad3cc2 (patch)
tree84967fd982d2e9c8606665fb58762567e17f15bb /nix/users/fcuny/home-manager.nix
parentrefactor home-manager (diff)
downloadworld-5e31b3dd64f090f9405d9ab9e8e63093b8ad3cc2.tar.gz
some more cleanup
Diffstat (limited to '')
-rw-r--r--nix/users/fcuny/home-manager.nix21
1 files changed, 6 insertions, 15 deletions
diff --git a/nix/users/fcuny/home-manager.nix b/nix/users/fcuny/home-manager.nix
index a344151..7752328 100644
--- a/nix/users/fcuny/home-manager.nix
+++ b/nix/users/fcuny/home-manager.nix
@@ -1,8 +1,6 @@
 { darwin, ... }:
 
-{ config, lib, pkgs, ... }:
-let isLinux = pkgs.stdenv.isLinux;
-in {
+{ config, lib, pkgs, ... }: {
   home.stateVersion = "23.05";
 
   xdg.enable = true;
@@ -15,16 +13,6 @@ in {
       # encryption
       age
 
-      # media
-      mpv
-      ffmpeg
-
-      # dicts
-      aspell
-      aspellDicts.en
-      aspellDicts.en-computers
-      aspellDicts.en-science
-
       # nix
       nil
       nix-direnv
@@ -32,11 +20,14 @@ in {
       nixfmt-classic
       nixpkgs-fmt
       nil # nix lsp
-
-    ] ++ (lib.optionals (isLinux) [ htop ]) ++ (lib.optionals (darwin) [
+    ] ++ (lib.optionals (darwin) [
       # hashicorp
       boundary
       nomad-pack
       tfswitch
+
+      # media
+      mpv
+      ffmpeg
     ]);
 }