about summary refs log tree commit diff
path: root/nix/users/fcuny/go.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-12-19 12:54:16 -0800
committerFranck Cuny <franck@fcuny.net>2024-12-19 12:54:16 -0800
commitbc40b7e0ad2ef5960b7f1695b4520909252a0e49 (patch)
treef22e9e5001720bbc82055a5d4d3b24077b9647de /nix/users/fcuny/go.nix
parentuse treefmt to format all the files (diff)
downloadworld-bc40b7e0ad2ef5960b7f1695b4520909252a0e49.tar.gz
switch to the newer version of nixfmt
`nixfmt-rfc-style' replaces `nixfmt-classic'. It's actively
maintained, but also changes the style, so this commit touches all the
files in the repository.
Diffstat (limited to '')
-rw-r--r--nix/users/fcuny/go.nix16
1 files changed, 13 insertions, 3 deletions
diff --git a/nix/users/fcuny/go.nix b/nix/users/fcuny/go.nix
index b52f89e..401abe3 100644
--- a/nix/users/fcuny/go.nix
+++ b/nix/users/fcuny/go.nix
@@ -1,11 +1,21 @@
-{ config, pkgs, ... }: {
-  home.packages = with pkgs; [ go-tools golangci-lint gopls delve ];
+{ config, pkgs, ... }:
+{
+  home.packages = with pkgs; [
+    go-tools
+    golangci-lint
+    gopls
+    delve
+  ];
 
   programs.go = {
     enable = true;
     goPath = ".local/share/pkg.go";
     goBin = ".local/bin.go";
-    goPrivate = [ "github.rbx.com/*" "github.com/fcuny/*" "git.fcuny.net/*" ];
+    goPrivate = [
+      "github.rbx.com/*"
+      "github.com/fcuny/*"
+      "git.fcuny.net/*"
+    ];
   };
 
   home.sessionPath = [ config.home.sessionVariables.GOBIN ];