about summary refs log tree commit diff
path: root/nix/users/fcuny/git.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-12-19 12:54:16 -0800
committerFranck Cuny <franck@fcuny.net>2024-12-19 12:54:16 -0800
commitbc40b7e0ad2ef5960b7f1695b4520909252a0e49 (patch)
treef22e9e5001720bbc82055a5d4d3b24077b9647de /nix/users/fcuny/git.nix
parentuse treefmt to format all the files (diff)
downloadworld-bc40b7e0ad2ef5960b7f1695b4520909252a0e49.tar.gz
switch to the newer version of nixfmt
`nixfmt-rfc-style' replaces `nixfmt-classic'. It's actively
maintained, but also changes the style, so this commit touches all the
files in the repository.
Diffstat (limited to '')
-rw-r--r--nix/users/fcuny/git.nix18
1 files changed, 11 insertions, 7 deletions
diff --git a/nix/users/fcuny/git.nix b/nix/users/fcuny/git.nix
index c89454b..9f7023a 100644
--- a/nix/users/fcuny/git.nix
+++ b/nix/users/fcuny/git.nix
@@ -1,4 +1,5 @@
-{ lib, pkgs, ... }: {
+{ lib, pkgs, ... }:
+{
   home.packages = with pkgs; [
     gitAndTools.pre-commit
     git-credential-manager
@@ -10,7 +11,9 @@
     userName = "Franck Cuny";
     userEmail = "franck@fcuny.net";
 
-    aliases = { amend = "commit --amend"; };
+    aliases = {
+      amend = "commit --amend";
+    };
 
     # https://stackoverflow.com/questions/74012449/git-includeif-hasconfigremote-url-not-working
     # to test it's working as expected:
@@ -19,17 +22,18 @@
     includes = [
       {
         condition = "hasconfig:remote.*.url:git@github.rbx.com:*/**";
-        path = pkgs.writeText "username.cfg"
-          (lib.generators.toGitINI { user.email = "fcuny@roblox.com"; });
+        path = pkgs.writeText "username.cfg" (lib.generators.toGitINI { user.email = "fcuny@roblox.com"; });
       }
       {
         condition = "hasconfig:remote.*.url:git@github.com:Roblox/**";
-        path = pkgs.writeText "username.cfg"
-          (lib.generators.toGitINI { user.email = "fcuny@roblox.com"; });
+        path = pkgs.writeText "username.cfg" (lib.generators.toGitINI { user.email = "fcuny@roblox.com"; });
       }
     ];
 
-    ignores = [ ".envrc" ".direnv" ];
+    ignores = [
+      ".envrc"
+      ".direnv"
+    ];
 
     extraConfig = {
       core.whitespace = "trailing-space,space-before-tab";